iPod Touch 4

One day after I briefed, Macworld magazine tells me that iOS 7, due out this fall will not work on a Touch 4, only on the Touch 5. Given this, if you decide you can use an iTouch, I'd recommend buying the new iPod Touch 5. Or maybe even waiting for the iPod Touch 6, which might appear in stores with iOS 7 this fall.  Jeff

Twitter Digg Delicious Stumbleupon Technorati Facebook Email

No comments yet... Be the first to leave a reply!

Leave a Reply

You must be logged in to post a comment.